Support Center

The Website Isn't Functioning As It Should

Last Updated: Mar 29, 2017 05:42AM PDT

If you are having difficulties with the general functionality of the FreeConference.com website, such as scheduling calls or making purchases, it may be because you are using an older operating system or browser version. The main reason that this can cause issues is because of security updates made to our website that are no longer compatible with older browsers.

 

*Note that if you are experiencing issues and are not using any of the below mentioned operating systems, then please do submit a ticket*
 

The following Operating Systems are no longer supported by Chrome since these platforms are also no longer actively supported by Microsoft and Apple:

- Windows XP
- Windows Vista
- Mac OS X 10.6 Snow Leopard
- Mac OS X 10.7 Lion
- Mac OS X 10.8 Mountain Lion

 

As of April 2016, Chrome will continue to function on these platforms but will no longer receive updates and security fixes.
 

Any versions of Internet Explorer below number 11 are also no longer supported by Microsoft, so it is likely that you will encounter difficulties when using Internet Explorer 10 or under. We also suggest that you upgrade to a newer browser for your own general benefit, as older browsers are less stable and much more vulnerable to viruses, spyware, malware, and other security issues.

 

Our website is optimized for Google Chrome as it is the most secure browser and supports the WebRTC technology required for our Video and Screen Sharing options. For a safer, more secure and better quality service, we recommend using the most up to date version of Google Chrome, along with a more recently updated Operating System.
 

Contact Us

24ccab8f391ad98560a0b4887ed939a2@iotum.desk-mail.com
https://cdn.desk.com/
false
desk
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete?b_id=7927